朝起きたらWin10がCreators Updateになってた

朝起きたらwindowsさんが別人になってた。

前回からの続きになるのでしょうか・・・。

今回、勝手に「Windows 10 Fall Creators Update」へアップデートしたってことは不具合直ったと考えていいですよね?Microsoftさん?!

2018/2/5 問題事項を追加:Arma3が「bad_module_info」でクラッシュする。

2018/2/7 問題事項を追加:ShadowPlayに不具合

2018/3/28 Arma3の「bad module info」についての記事を掲載

前回2017/12/16の時点では、私のPC環境だとアップデート後にGPUのトラブル発生して全く使い物にならず即元のバージョンに戻しました。

現在のバージョンは1709、ビルドが16299.125。
2018/3/4ビルド16299.248

果たして・・・

前回の問題点を確認


前回のGPUのトラブルはドライバが正常に適用されず、延々とインストールを求められかつGPUがマルチディスプレイに対応できなくたった。

今回のOSアップデートで行ったGeForceアップデートのバージョン390.77では再びインストールを求められるようなことはなくExperienceも一応正常に動作しているようです。マルチディスプレイも出来ています。ShadowPlayもデスクトップ上のキャプチャは正常動作しています。ただ、時々HUDのステータスがちらつくのが気になりますが。=>以下チェック欄に追加

個人的ソフトウェアの動作チェック


  • Adobe関連

仕事にも使う割と重要なもの。過去に作成したプロジェクトを開いてみた。

Premiere Proは問題なくレンダリングされて動きも悪くないです。PhotoshopとCharacter animatorなどアニメーション連動のシーケンスもストレスなく編集出来ている感じです。

ただ、Media Encoderがやたら重い。以前やった時は数十分ほどだったのが、今は2時間半かかっている?!特に重いのはアニメーション関係。ただ単に動画を切って貼って作るものは早いんですが、アニメーションは複数アプリと連携しているからだろうか・・・。でも、Premiere Proから書き出しだと早いんですよね。

  • Autodesk Fusion 360

こちらは、特にモデル、レンダリングなど問題なく動作しているようです。

  • Tom Clancy’s Rainbow Six Siege

一番心配していたこの子(ぇ
プレイ中のfpsは安定していて問題なさそうなんですが1つ気になるのが。時々、クラッシュするんです。てか、アップデートは今日したわけで数えてないけど回数としては多い。なければ長時間続けてできますが嫌な感じです。

GPU使いそうなソフトは試してみました。他のArduino IDEやExcelなんかは多分大丈夫でしょう。どうせArduinoの作業する時に使うことになるし・・・後回しに。

  • Arma3(2018/2/5追加)

致命的な問題がありました。
プレイ開始して大体十数分経つと「bad_module_infoは動作を停止しました」とエラーが発生し終了してしまいます。

以前は、このような現象は一切確認できなかったので恐らく今回のアップデートが原因でしょう。

対策は現在模索中です。
=>2018/3/4、下の5番目で現在安定

試したのは今のところ以下の通り。(アップデートか何かで解決するまで更新するつもり)

  1. Arma3のパラーメーターのメモリーアロケータを3種全て。
    =>NG
  2. アプリケーションの互換性:全画面表示の最適化を無効にする。にチェック。
    =>NG
    これはエラー名称で検索してヒットした対策の一つとされているようです。
    プレイするとfpsが10%程度向上していました。が、やはりエラーで落ちる。
    PUBGでもこれで解決することがあるようです。
    (R6Sで適用したらラウンド毎のキル数増えた・・・気がするだけかもしれない)
  3. Arma3のmodを外してシングルプレイをする。
    =>OK
    これだと問題なしにプレイができます。何か相性の悪い処理があるのだろうか?
  4. 起動オプションを設定する。
    =>OKNG
    今の所これで安定しています。この数日の間、そこそこ長い時間プレイしてきましたが2018/2/7の時点で一度だけクラッシュしました。私の環境では解決とならないようです。
    参考元:Problem with : Bad_Module_Info
    方法は、Steamのライブラリ一覧にあるArma3を右クリックしてプロパティを開き、「起動オプションを設定」を開くとテキストボックスがあるので「just write : -malloc=syste」と入力して設定すると出来ます。
    ただ、コードの意味を理解していないので別の不具合が発生することもあるかも知れませんので注意してください。
  5. 4.と組み合わせで互換モード「Windows7」、全画面表示の最適化を無効にするにチェック
    =>OK
    2018/3/4現時点でこれが一番安定してます。
    プロパティを変更するのは「arma3.exe」「arma3_x64.exe」「arma3battleye.exe」「arma3launcher.exe」の4つ。場所は初期設定で「C:\Program Files (x86)\Steam\steamapps\common\Arma 3」
    以前は15分程度プレイするとエラーが出ていましたがこの設定にしてからエラーは出ていません。
  6. 5.で駄目ならwindowsの設定にあるゲーム関係を変更
    windowsの設定→ゲームにあるゲームバーをオフ、ゲームDVRのバックグラウンドで記録をオフにすると改善することがあるようです。
  7. Geforce EXPERIENCEでゲームを最適化
    海外フォーラムでこれで改善された報告がありましたので参考に。

NG付は私の環境で駄目だったものです。海外サイトなどでは解決する例もあるようです。

エラー内容を見るとGPU関連のワードが出てくるのでもしかしたら、また前回と同じくマルチディスプレイに不具合があったように相性の問題かもしれませんね。

他に参考になりそうな情報

Microsoft : PC ゲームのパフォーマンスを向上する方法

  • ShadowPlay (2018/2/7追加)

前からステータスのちらつきが気になっていたのですが、やはり録画時に影響がありました。インスタントリプレイのみ試してみましたが録画をすると動画が不定期に数フレーム止まる、フリーズするような状態になります。ゲームなどに支障はないのですが良いシーンが撮れた時は困りますね・・・。

更に2018/2/17追加

録画した動画が途中で音声のみになってしまう対処法がわかりました。ツイッターでも書きましたが、ビットレートを高くすると発生しやすいようです。いくつかパターンを検証しましたが、ユーザー(PC環境)ごとに症状の出るビットレートサイズは異なるようで、これ以下にして下さいとは現状言えません。

個々でビットレートを調整、確認しつつ対応するしかないようです。
=>2018/2/26追加
バージョン391.01で再び録画した動画が途中から音声のみになる現象を確認しました。発生条件は正確には分かってないですが、個人的に確認したのはsteamをログアウト/ログインする丁度のタイミングで映像が必ず切れます(デスクトップ録画可の状態で。
症状は未解決。ビットレートの調整では解決せず映像が切れる時間も不規則になっています。

トラック分離でメインにサブ音声が一瞬入ってしまう不具合とフレームが時々飛ぶ現象の改善方法は現在調査中です。ちなみにGPUのクリーンインストールでは解決できなかったです。

  • 周辺機器関連 (2018/2/11)

最近FPSやってるとエイムが終わってるな・・・年かな?なんて思ってたらどうやらアップデートでマウスも不具合が起こるようで。

どう判断したかと言うと、単純にカーソルが円を描くように動かす。
すると、なぜだか時々下方及び右方へカーソルが移動するような挙動をするようになっていたのを確認しました。

マウスやマウスパッドを変えても同様の現象が発生します。

これらに関しては簡単にドライバの再インストールで一応改善は見られましたので、同じ現象が現れている方は試してみてはいかがでしょうか。と、言っても再起動後にまた発生することがあるのでMicrosoftさんには説教をしたくなるところです( ˘•ω•˘ )

他、対策は随時

更新は毎日確認しておこう


とりあえず前のような大きなトラブルは無いので、このままにして様子を見てみます。
とは言ってもバックアップデータが70GBもあり消したいところだが・・・それをやると戻れなくなる・・・。

更新プログラムが入れば改善する可能性もありますので外部HDDで我慢しながら期待しつつですかね。

スポンサーリンク







シェアする

フォローする

スポンサーリンク